gtk+-2.0-0


※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

Why build gtk+-2.0 by myself?

Currently, Ubuntu 8.04 uses libgtk+-2.0-0 package.
However, libgtk+-2.0-0-dev package does not exist.
So I build package.

How to build gtk+-2.0

apt-get source libglib2.0-0
cd glib2.0-2.16.3
./configure --prefix=/usr
make
sudo make install

apt-get source libatk1.0-0
cd atk1.0-1.22.0
./configure --prefix=/usr
make
sudo make install

apt-get source libcairo2
cd cairo-1.6.0
./configure --prefix=/usr
make
sudo make install

apt-get source libpango1.0-0
cd pango1.0-1.20.1
./configure --prefix=/usr
make
sudo make isntall

apt-get source libgtk2.0-0
cd gtk+2.0-2.12.9
./configure --prefix=/usr
make
sudo make install

Note:

if gtk+-2.0 configure faile then you might fix configure script
- ac_cv_func_XOpenDisplay=no
+ ac_cv_func_XOpenDisplay=yes
- ac_cv_func_XextFindDisplay=no
+ ac_cv_func_XextFindDisplay=yes

if you want to create deb package...

sudo apt-get install build-essential fakeroot devscripts
ツールボックス

下から選んでください:

新しいページを作成する
ヘルプ / FAQ もご覧ください。